Wednesday, October 24, 2012

The Fontconfig Affair

(Sorry, I had a flashback to the days of The Man from U.N.C.L.E.)

For those of us who use Linux, there's a library called "fontconfig" that has changed in a way that breaks Second Life clients.

The version in question, 2.9.0, is present in the recently-released Ubuntu 12.10, so I suspect that many more are tripping over the problem now.

Third-party viewers are proving quicker to respond to the issue than LL. The upcoming Firestorm 4.3 will not have the problem. In the meantime, the fix from thickbrick.sleaford in the Firestorm JIRA page for the problem works.

2 comments:

Ioannis Vranos said...
This comment has been removed by the author.
Ioannis Vranos said...

I figured a way to make Second Life client run in Ubuntu / Xubuntu / Lubuntu 12.10 32-bit, by fixing the fontconfig issue, until Linden Lab fixes the client:
http://freesoftwaredeveloper.blogspot.gr/2012/12/how-to-run-second-life-in.html